Jump to content


Photo

Enrollment error code 12007


  • Please log in to reply
9 replies to this topic

#1 Jas

Jas

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 March 2015 - 04:21 PM

Hello,

 

I'm testing enrolling myself before i deploy company wide, i'm getting the following error when i log into my system to enroll:

 

Automatic user enrollment failed: Unknown error (Error code:12007, URL:http://subdomain.exa...lecreated.asp).
 
Please contact your system administrator is this problem persists.

 

Thanks.



#2 Seth Bartlett

Seth Bartlett

    Member

  • Administrators
  • PipPip
  • 15 posts
  • Gender:Male

Posted 17 March 2015 - 07:09 PM

Please try opening the web browser on the machine you are getting the error on and send me the results:
 
 
Also, does this happen right when the enrollment wizard opens, or after you fill out questions/answers?
 
Please try the following KB as well:
 


#3 Jas

Jas

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 March 2015 - 01:31 PM

when i visit the page via browser i get prompted for credentials, when i enter credentials it keeps prompting for credentials.

 

the error message comes up right away when i login to my system.



#4 Seth Bartlett

Seth Bartlett

    Member

  • Administrators
  • PipPip
  • 15 posts
  • Gender:Male

Posted 18 March 2015 - 02:33 PM

This usually occurs when Anonymous authentication is not turned on for the Default PM instance. Follow the steps below(I have also included a screenshot at the bottom of this post):

  1. Open IIS Manager
  2. Expand Default Web Site
  3. Click on PM
  4. On the right side click on "Authentication"
  5. Set Anonymous Authentication to Enabled (If this does not work, set Windows authentication to Disabled as well).

Afterwards, test that you can access the servername/PM website and that it loads properly before testing the client.

 

http://prntscr.com/6iawf7



#5 Jas

Jas

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 18 March 2015 - 04:50 PM

Hey Seth,

 

Set Anonymous Authentication to Enabled and also Windows Auth is enabled which did the trick now i can enroll but my issue is when i visit my external address via web its logs on the person right away with any credentials. How can i lock it so user has to put the credentials in to access the enrollment page.

 

Thanks.



#6 Seth Bartlett

Seth Bartlett

    Member

  • Administrators
  • PipPip
  • 15 posts
  • Gender:Male

Posted 23 March 2015 - 01:27 PM

Jas,

 

This is expected behavior because this is the Self-Service Portal. It is for users to Enroll, Unlock, Reset and Change their password. If they had to punch in credentials, there would be no way for them to Unlock/Reset their password. So if you needed to reset your password because you forgot it, you would be stuck on trying to login to the Self-Service Portal :)



#7 Jas

Jas

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 24 March 2015 - 01:35 PM

thanks, can you do me a favor and remove my selfserve portal address?



#8 Seth Bartlett

Seth Bartlett

    Member

  • Administrators
  • PipPip
  • 15 posts
  • Gender:Male

Posted 24 March 2015 - 03:54 PM

Done, sorry about that :)



#9 ajdtech

ajdtech

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 March 2015 - 04:04 AM

I'm also testing the password manager currently and am getting the 12007 error. I currently have Password Manager installed on a Windows 7 machine and when I launch Enrollment icon on that machine it works fine. On the Windows 8.1 machine on my network I get the 12007, but I can get to the web interface of Password Manager just fine from any machine on the network and even outside the network if I open port 80 to it. I checked the IIS settings and I do have Anonynmous Authentication enabled as was suggested above. Any ideas?

 

Thanks,

-Al



#10 Seth Bartlett

Seth Bartlett

    Member

  • Administrators
  • PipPip
  • 15 posts
  • Gender:Male

Posted 31 March 2015 - 12:34 PM

This may come down to an improper link. When you visit the link on the 8.1 machine, the page loads fine? No certificate warnings or anything?

 

With the improper link, please look at the following KB and make sure the PRM_Server link is correct:

 

https://www.netwrix.com/kb/1500






0 user(s) are reading this topic

0 members, guests, anonymous users