Jump to content


Photo

Exchange change reporter issue


  • Please log in to reply
4 replies to this topic

#1 Vladimir Angelov

Vladimir Angelov

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 October 2014 - 01:29 PM

Hello,

I apologize if this was already posted, but I was unable to find it. After installing the Active Directory Change reporter (freeware) and testing it I got the below error for the Exchange:
10/13/2014 3:52:51 PM: Server: EXCHANGE:: Unable to get audit data for MS Exchange Server via WMI. The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

Could you please advise what might be the reason?

Thank you!

#2 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 384 posts
  • Gender:Male

Posted 13 October 2014 - 02:32 PM

Valdimir,

Typically when I see this error it is actually a non existent Exchange server that still exists in AD. Of course that could easily not be the case and simply WMI communication is not able to be achieved between the Netwrix server and that particular Exchange server. Also, it probably doesn't matter with this particular error but make sure the account that is running the collections is in the Exchange Organization Management group. Also, of course, make sure the WMI and RPC services are running on the Exchange server. If that doesn't help then the question is what other Exchange servers are there and do you get changes for the other ones? If so, what is the difference between them? If there is no difference then perhaps scheduling a reboot off hours would help (last resort of course).

-Jeff

#3 Vladimir Angelov

Vladimir Angelov

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 October 2014 - 02:50 PM

Hello,

Thank you for your quick reply. I am sorry that I forgot to mention that we have a DAG with two Exchange 2010 servers. Could you please LMK which services to check exactly?

Thanks!

Valdimir,

Typically when I see this error it is actually a non existent Exchange server that still exists in AD. Of course that could easily not be the case and simply WMI communication is not able to be achieved between the Netwrix server and that particular Exchange server. Also, it probably doesn't matter with this particular error but make sure the account that is running the collections is in the Exchange Organization Management group. Also, of course, make sure the WMI and RPC services are running on the Exchange server. If that doesn't help then the question is what other Exchange servers are there and do you get changes for the other ones? If so, what is the difference between them? If there is no difference then perhaps scheduling a reboot off hours would help (last resort of course).

-Jeff



#4 Vladimir Angelov

Vladimir Angelov

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 13 October 2014 - 02:52 PM

I just saw your wrote RPC and WMI, both are up and running

Hello,

Thank you for your quick reply. I am sorry that I forgot to mention that we have a DAG with two Exchange 2010 servers. Could you please LMK which services to check exactly?

Thanks!



#5 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 384 posts
  • Gender:Male

Posted 14 October 2014 - 01:22 PM

Vladamir,

So to be clear you have two Exchange servers in a DAG so there is only one that we would be communicating with at any one time? You didn't mention any of the other things I had asked to check. Although you may not think they are important please check them as well. Also, please disable the firewall temporarily on both the Netwrix server AND the Exchange server for testing purposes.

-Jeff




0 user(s) are reading this topic

0 members, guests, anonymous users