Jump to content


Photo

PAM Freeware IIS Issue


  • Please log in to reply
4 replies to this topic

#1 KGradert13

KGradert13

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 May 2012 - 03:36 PM

I'm on my 3rd attempt to install PAM onto one of our 2008R2 machines, and each time I am encountering the following:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.


Module DynamicCompressionModule
Notification SendResponse
Handler SSINC-html
Error Code 0x8007007e
Requested URL http://localhost:80/PAM/Default.html
Physical Path C:\Program Files (x86)\NetWrix\Privileged Account Manager\WebSite\Default.html
Logon Method Not yet determined
Logon User Not yet determined


Has anyone had this issue previously? If so, any fix?

#2 Tommy Garvin

Tommy Garvin

    Advanced Member

  • Members
  • PipPipPip
  • 92 posts
  • Gender:Male
  • Location:Tampa, FL

Posted 07 May 2012 - 12:56 PM

Hello KGradert13, Welcome to the NetWrix Forums!

Please see the following MSDN article: http://blogs.msdn.co...s-in-iis-7.aspx :

For above specific error (mentioned in this example), DynamicCompressionModule module is causing the trouble. This is because of the XPress compression scheme module (suscomp.dll), which gets installed with WSUS. Since Compression schemes are defined globally and try to load in every application Pool, it will result in this error when 64bit version of suscomp.dll attempts to load in an application pool which is running in 32bit mode.

This module entry looks like:

<scheme name="xpress" doStaticCompression="false" doDynamicCompression="true"
dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10"
dynamicCompressionLevel="0" />

Hence to get rid of this problem:

Remove/Disable the XPress compression scheme from the configuration using the command below:
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

-OR-

Add an attribute of "precondition= "64bitness" for this module entry so that it loads only in 64bit application pools

- Tommy

#3 Menz

Menz

    Member

  • Members
  • PipPip
  • 10 posts

Posted 27 June 2014 - 03:38 PM

Hello KGradert13, Welcome to the NetWrix Forums!

Please see the following MSDN article: http://blogs.msdn.co...s-in-iis-7.aspx :

For above specific error (mentioned in this example), DynamicCompressionModule module is causing the trouble. This is because of the XPress compression scheme module (suscomp.dll), which gets installed with WSUS. Since Compression schemes are defined globally and try to load in every application Pool, it will result in this error when 64bit version of suscomp.dll attempts to load in an application pool which is running in 32bit mode.

This module entry looks like:

<scheme name="xpress" doStaticCompression="false" doDynamicCompression="true"
dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10"
dynamicCompressionLevel="0" />

Hence to get rid of this problem:

Remove/Disable the XPress compression scheme from the configuration using the command below:
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

-OR-

Add an attribute of "precondition= "64bitness" for this module entry so that it loads only in 64bit application pools

- Tommy



i just installed PAM to a windows 2012 R2 server and i am getting the same error. the link in the above post does not work and i do not know how to fix this issue. can anyone help??

#4 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 384 posts
  • Gender:Male

Posted 27 June 2014 - 06:31 PM

Menz,

This freeware product has not been tested on IIS 8 or 8.5. You can try enabling all features available in IIS but this is untested and likely will not be tested by development unless it is removed from being freeware.

-Jeff

#5 Menz

Menz

    Member

  • Members
  • PipPip
  • 10 posts

Posted 02 July 2014 - 02:37 PM

just figured out my issue... this is for everyone else. its a simple fix. open IIS and click application pools. PAM will probably be set .Net v4.0. just change that to v2.0 and reboot and issue should be solved




0 user(s) are reading this topic

0 members, guests, anonymous users