Jump to content


Photo

GP Change Reporter XML Error


  • Please log in to reply
7 replies to this topic

#1 CRHITSUPPORT

CRHITSUPPORT

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 September 2014 - 08:02 AM

Hi,

Using the freeware version and very keen to get it working correctly to show the value I think the product has. The Active Directory report works fine but the Group Policy Change Reporter Summary email always comes back with:

Change analysis for domain *** completed with error: There is an error in XML document (69, 17).
Change analysis for domain *** completed with warnings and/or errors. Please see the bottom of this report for details.

I have uninstalled and reinstalled and deleted Folders from ProgramData and ProgramFiles, as well as removing exisitng task as a starter but no joy.
Any help would be greatly appreciated.

#2 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 372 posts
  • Gender:Male

Posted 10 September 2014 - 01:50 PM

CRHITSUPPORT,

Would you be able to go into the product install directory and locate the Tracing folder? Please zip this folder and upload it to www.netwrix.com/upload and put CRHITSUPPORT_Forum in the subject. I will see if the tracing is helpful in determining what XML file is failing to be parsed.

-Jeff

#3 CRHITSUPPORT

CRHITSUPPORT

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 10 September 2014 - 02:37 PM

Files uploaded as requested. Thanks Jeff


CRHITSUPPORT,

Would you be able to go into the product install directory and locate the Tracing folder? Please zip this folder and upload it to www.netwrix.com/upload and put CRHITSUPPORT_Forum in the subject. I will see if the tracing is helpful in determining what XML file is failing to be parsed.

-Jeff



#4 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 372 posts
  • Gender:Male

Posted 11 September 2014 - 02:22 PM

Alright so this is the file of concern. Go ahead and upload this one when you get a chance using the same instructions:

C:\ProgramData\NetWrix\Management Console\Data\AD Changes\DOMAIN\2014_9_10_7_51_20.gpcrf\gp_result.xml

-Jeff

#5 CRHITSUPPORT

CRHITSUPPORT

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 11 September 2014 - 02:31 PM

Uploaded as requested Jeff. Thanks again

#6 jeffb

jeffb

    Advanced Member

  • Administrators
  • PipPipPip
  • 372 posts
  • Gender:Male

Posted 11 September 2014 - 02:35 PM

Okay this is the GPO which we are failing to parse:
<GroupPolicyResult>
<Name>Java&#x1F;_Del</Name>
<Id>{421F8722-2C2A-47A1-A0BA-50B55A5E118F}</Id>
<Result>Success</Result>
<Error />

System.Xml.XmlException: '', hexadecimal value 0x1F, is an invalid character. Line 52, position 13.

Thoughts? What does this GPO appear to be called in the GUI?

-Jeff

#7 CRHITSUPPORT

CRHITSUPPORT

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 11 September 2014 - 02:44 PM

The GUI displays "Java_Del" as the name with no odd or special characters on screen.

#8 CRHITSUPPORT

CRHITSUPPORT

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 11 September 2014 - 02:51 PM

Renamed the policy and re-ran the Scheduled Task. Email came through with same error but found I didn't need the GPO after all so deleted it. Ran the Scheduled Task again and email came through formatted properly with the renamed GPO reporting as Removed.

Many thanks for the help.




0 user(s) are reading this topic

0 members, guests, anonymous users