Jump to content


Photo

IIS error installing PasswordManager


  • Please log in to reply
4 replies to this topic

#1 EvenStevenDeven

EvenStevenDeven

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 17 October 2011 - 11:48 PM

Hello,

I just downloaded the latest version of the freeware PasswordManager. I delegated a user that only has rights to reset passwords, and entered his username/password in the first install screen. When I get to the next page that asks me for the "Website" and "Virtual Directory" names, I enter a custom name for each (the default "Website" name is w3svc1, so I change that to an easier to remember name).

After I hit Next I get the following error:

"Error occured while creating IIS Virtual Directory 'PM': The system cannot find the path specified.. Available Websites are: W3SVC1(Default Web Site)"

I did make sure to "Run as Administrator" when I launched the install executable.

Did I miss anything? Do I have to give the user more rights than just resetting passwords? I really don't want my end-users to have to type in an odd URL name like "w3svc1" when accessing the portal.

Thanks!

#2 Brian Stern

Brian Stern

    Advanced Member

  • Technical Support
  • PipPipPip
  • 259 posts

Posted 19 October 2011 - 06:06 PM

Hello,

I just downloaded the latest version of the freeware PasswordManager. I delegated a user that only has rights to reset passwords, and entered his username/password in the first install screen. When I get to the next page that asks me for the "Website" and "Virtual Directory" names, I enter a custom name for each (the default "Website" name is w3svc1, so I change that to an easier to remember name).

After I hit Next I get the following error:

"Error occured while creating IIS Virtual Directory 'PM': The system cannot find the path specified.. Available Websites are: W3SVC1(Default Web Site)"

I did make sure to "Run as Administrator" when I launched the install executable.

Did I miss anything? Do I have to give the user more rights than just resetting passwords? I really don't want my end-users to have to type in an odd URL name like "w3svc1" when accessing the portal.

Thanks!


Dear EvenStevenDeven,

Thank you for your Forum post.

W3SVC1 is a special name used by IIS for the Default Web Site. Users will not have to type "w3svc1" in order to access the portal - they will have to type <name of Password Manager server>/PM instead.
Please launch the installation wizard again and specify W3SVC1 as a web site to install the software on.

I hope I have been of some assistance. Please let me know if you have any further questions or issues.

Sincerely,
Brian Stern
Technical Support Engineer

#3 EvenStevenDeven

EvenStevenDeven

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 20 October 2011 - 12:37 AM

Ah, ok thank you Brian!

I now get an error after that screen, which states:

"Error occured while enabling ASP extension on IIS server. Error code: -2146646015"

I am pretty sure I installed all the ASP and other prerequisites for the installation.

#4 Brian Stern

Brian Stern

    Advanced Member

  • Technical Support
  • PipPipPip
  • 259 posts

Posted 21 October 2011 - 02:48 PM

Ah, ok thank you Brian!

I now get an error after that screen, which states:

"Error occured while enabling ASP extension on IIS server. Error code: -2146646015"

I am pretty sure I installed all the ASP and other prerequisites for the installation.


Dear EvenStevenDeven,

Thank you for your Forum post.

You can usually get this error when you do not have the ASP module for IIS enabled.

To enable the ASP module on Windows 2008, please perform the following steps:

1. Open Server Manager->Roles->Web Server(IIS). Right click on it and choose Add Role Services.
2. Choose ASP in Application Development and install it.

To enable the ASP module on Windows Vista or Windows 7, please perform the
following steps:

1) Open Programs and Features (Control Panel -> Programs and Features)
2) Select Turn Windows features on or off
3) Open the following node: Internet Information Services (IIS) -> Web Server (World Wide Web Services) -> Application Development
4) Select the ASP and ASP.net items. Click Next and click Install
5) Click Finish to exit the installation wizard and try to install Password Manager again

Please let me know if the above steps resolve this issue. I await your reply.

Sincerely,
Brian Stern
Technical Support Engineer

#5 EvenStevenDeven

EvenStevenDeven

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 21 October 2011 - 04:39 PM

Dang, that was it. I was pretty sure I installed it for IIS, but I only chose the general ASP install not specific to IIS earlier.

Thank you!




0 user(s) are reading this topic

0 members, guests, anonymous users